67

0

Kutty

Kutty 是一个用于构建 Web 应用程序的Tailwind 插件。它具有一组可访问且可重用的组件,这些组件通常用于 Web 应用程序

Kutty

Kutty 是一个用于构建 Web 应用程序的顺风插件。它具有一组可访问且可重用的组件,这些组件通常用于 Web 应用程序。


另请参阅mynaui.com

  • [X] 无需任何插件即可制作的 TailwindCSS UI 组件和模板。
  • [X] 开源。
  • [X] 完全响应和可访问。

安装

npm install kutty --save

此插件需要 Tailwind CSS 3 或更高版本。Tailwind CSS 不包含在此软件包中。在此处了解如何安装顺风

用法

对于 CSS

需要将已安装的插件直接添加到您的 Tailwind 配置中:

// tailwind.config.js
plugins: [require("kutty")],

对于 JS

我们捆绑了 AlpineJS v2.8.0 以在我们的组件中进行反应。在此处了解有关AlpineJS 的更多信息。将以下脚本标记放在结束正文标记之前。

<!-- All components in one -->
<script src="https://cdn.jsdelivr.net/npm/kutty@latest/dist/kutty.min.js"></script>
<!-- Single component -->
<!-- Include AlpineJS first -->
<script src="https://cdn.jsdelivr.net/npm/kutty@latest/dist/alpinejs.min.js"></script>
<!-- And then the single component -->
<script src="https://cdn.jsdelivr.net/npm/kutty@latest/dist/dropdown.min.js"></script>

文档

在https://kutty.netlify.app查看完整文档。